Correção: O .NET Framework 4.7 não é suportado neste sistema operacional

Advise: Clique Aqui Para Corrigir Erros Do Windows E O Desempenho Do Sistema Otimizar

.Net Framework é uma infra-estrutura de programação introduzida pela Microsoft. Você precisará do .Net Framework para executar vários aplicativos e serviços diferentes. A maioria dos aplicativos que requerem o .Net Framework também vem com seus arquivos de instalação. Então, ele será instalado automaticamente no seu sistema ao instalar um aplicativo. Mas, você pode ver um erro "O .NET Framework 4.7 não é suportado neste sistema operacional" ao instalar um aplicativo. Esse erro impedirá que você instale o aplicativo com êxito. Você pode ver esse erro ao tentar instalar o .Net Framework como um aplicativo / serviço independente.

A razão pela qual esse erro ocorre é a mesma mencionada na mensagem de erro. Embora o .Net Framework seja suportado no Windows 10, mas não é compatível com todas as versões do Windows 10. Portanto, se você estiver vendo esta mensagem, a causa mais provável desse erro é que você está executando uma versão do Windows 10 que não é compatível com o .Net Framework.

Método 1: atualizar o Windows 10

A única solução para este problema é simplesmente atualizar o Windows 10. É aconselhável verificar se há atualizações do Windows, mesmo se você estiver na versão mais recente do Windows 10. Como o problema é causado por um sistema operacional incompatível, a instalação de todo o Windows 10 disponível as atualizações provavelmente resolverão o problema. Você também pode verificar a versão exata do seu Windows 10 e a versão exigida pelo .Net Framework seguindo as etapas abaixo.

  1. Segure a tecla Windows e pressione R
  2. Digite winver e pressione Enter

  1. Sua versão deve ser mencionada na janela recém aberta. O número após a versão (na segunda linha) é o seu número de versão. O número deve ser 1507 ou 1709. Os primeiros 2 dígitos são o ano e o segundo 2 representa o mês. Portanto, se você tiver uma versão 1709, isso significa que você está executando uma versão lançada em setembro de 2017

  1. Agora você precisa ter certeza de que você tem a versão do Windows 10 que é compatível com o .Net Framework. Clique aqui e clique nos Requisitos do Sistema

Se você olhar para a seção Sistema Operacional Suportado, ele diz Atualização do Windows 10 Anniversary e Windows 10 Creators . Como muitas pessoas não estão familiarizadas com os números de versão associados às atualizações de aniversário e criadores de conteúdo, mencionamos essas informações abaixo

  • Atualização de novembro (1511)
  • Atualização de aniversário (14393)
  • Atualização de Criadores (1703)
  • Atualização de criadores de outono (1709)
  • Atualização de criadores de primavera (1803)

Como você pode ver, a Atualização de Aniversário tem o número de versão 14393 e a Atualização de Criadores tem uma versão 1703. Portanto, se você tiver uma versão menor que a 14393, não poderá instalar o .Net Framework 4.7 no Windows 10. Agora basta atualizar o Windows e verifique se você tem a versão mais recente do Windows 10 e tente novamente.

Artigos Interessantes